No Map fixed frame?

I’m trying to work on the Nav course and in Units 1 and 2 the map fixed frame doesn’t exist. I manually type it in and it causes the Global status, RobotModel, and LaserScan to go into error states. If I set the fixed frame to base link those recover. Either way the map visualization stays in a warning state with no map received. I’ve tried restarting the sim a few times and that doesn’t fix it. Any idea what’s going on and how to fix it?

Hello @justin.smith ,

Can you please describe the steps followed in order to reproduce this issue? I’ve been doing some tests in Unit 1 right now and it is working ok for me.

Thanks for getting back to me, @albertoezquerro . For example, if I do example 1.2 the command for shell 1 puts out the following warning

[ WARN] [1643654100.594725607, 15.601000000]: No laser scan received (and thus no pose updates have been published) for 15.601000 seconds. Verify that data is being published on the/kobuki/laser/scan topic.

The command for shell 2 lets me change the velocity but not move the robot and RViz, from shell 3, comes up will a global status error of “Unknown Frame Map”. I ran all 3 commands in order, exactly how the exercise says to, and have tried restarting the sim as well with no luck.

Hello @justin.smith ,

I’m sorry, but I’m not able to reproduce your issue. Could you please record a video (capture your screen) of the whole process so that I can exactly see what you are doing and the issues you are having? You can send the video to me here: