Model and map not showing in rviz - Step 1: Generate a Map of the Environment

I built a gmapping.launch file copied from solution. (Note: The solution has typo error: map_udpate_interval)

I run roslaunch gmapping.launch and rosrun rviz rviz and it show me the rviz as picture below:

Model and map is not showing. Any idea on solving this issue?


Have you tried firts of all the demo:

roslaunch turtlebot_navigation_gazebo gmapping_demo.launch ?
rosrun rviz rviz ( added laser and map elements )

It should work. Did i work for you? Basically this i the solution given.

Sorry that I might not been clear enough at first. I am referring to the rosject: Section 1 of ROS Navigation Real Robot Project. I am not able to run those in this rosject either.


Are you currently working on the simulation?

What happens if you change the Fixed Frame to odom?

It doesnt change anything.

The exact code that I have copied into my rospy dependency package.

I don’t see any tfs from the turtlebot being published. Is your simulation running?

1 Like

Ahh forgot to run “roslaunch realrobotlab main.launch” after my restart. It works like a charm now, thanks alot :slight_smile: