Manipulation Course questions

Hello @albertoezquerro. Thank you so much for providing such an important and interesting course.

  1. some of the pictures are old like this one in unit 3.Screenshot from 2022-03-23 00-53-13.

We don’t have kin. solver attempts now right?

  1. Every time when we load the xacro model. A warning message will come up

I just want to confirm is this okay? I checked other topics and some of them said it is a known issue and no need to deal with it.

  1. When I follow your guidance to create a fetch robot. And run the
    roslaunch fetch_moveit_config fetch_planning_execution.launch

I got error message:

This is the launch file


  <include file="$(find fetch_moveit_config)/launch/planning_context.launch" >
    <arg name="load_robot_description" value="true" />

  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
    <rosparam param="/source_list">[/joint_states]</rosparam>

  <include file="$(find fetch_moveit_config)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />

  <include file="$(find fetch_moveit_config)/launch/moveit_rviz.launch">
    <arg name="config" value="true"/>


I can use command roslaunch fetch_moveit_config demo.launch to open the model with no issue

Thank you in advance

Hello @xj2106 ,

  1. Updated the image. No, Kin. Solver Attempts doesn’t appear now.

  2. Yes don’t worry, you can safely ignore it.

  3. Try modifying the argument config for rviz_config in your launch file, like this:

    <arg name="rviz_config" value="true"/>

Hope this helps,

Thank you @albertoezquerro. Now I encounter When I launch:
roslaunch fetch_gazebo_demo move_torso.launch

It worked Once when I added the robot model and motion planning into it, save the rviz config, and load them with the command
roslaunch fetch_moveit_config fetch_planning_execution.launch

After that I went through all of the python scripts with no issue.

Then I do not know what I did wrong, when I run the code again, an error message shows like this:
Python script shell:

MoveIt launch shell:

I tried to redo all of the stuff and I found out that the model shown in rviz was also wrong

But no python script running at this time, why did this happen? I must miss something really important in the note but I can not find them by myself. Can you kindly point it out for me?

I set up the grasping environment as you guided me, bu it seems like no object are found in the rviz

This is shell 2 and 3

@albertoezquerro. Unfortunately, the issue is still there…

Hello @xj2106 ,

About your Perception node, it is actually doing a detection since you are receiving the message in the result topic (at least for the object).

  • Make sure that you also add a display for the topic /basic_grasping_perception/object_cloud.

  • Also, make sure that you set up RViz properly before sending the goal to the perception action server. If you do it the other way, you won’t visualize the detections.

About the planning error, I’m not sure what’s the problem. The error/warning messages you are showing are normal, you can just ignore them. The problem is that it is not finding a valid motion. This can happen for many reasons. Could you record your screen so that we can better see what you are doing and how you are getting to this error?

Thank you. @albertoezquerro I moved on and started to do the ur3e project. For the the previous error ,you can see that in rivz model, window is showing two arms. Even when I shut everything down and start again. image

For the unit 8 project exercise. After I created moveit pkg, the rviz is showing the planning and executing results but gazebo isn’t. Why?
媒体4 (1)

And by default, there is no topic from camera.

Hello @xj2106 ,

  • For the issue of seeing 2 arms, try removing or commenting the following lines in your launch file:
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
    <rosparam param="/source_list">[/joint_states]</rosparam>
  • If the planning is working but it’s not being executed in Gazebo, it is most likely an error in the controllers.yaml file of your Moveit package. Make sure that the controller configuration is matching the Gazebo controller for the arm (/arm_controller/follow_joint_trajectory/...).

Thank you! @albertoezquerro
I will try to see if the problem will be fixed.