Launch file error exercise 3.6

I have been having this issue for over a couple of weeks and I have asked before but there has been no response. I have tried restarting the exercise multiple times but no change. Please could someone help thanks.

Hello @MustaphaJames ,

The problem is that you have not compiled your package after adding these files. If you don’t compile your package, the new files will not be installed in the workspace, thus ROS2 won’t be able to find them. This should get be solved just by compiling/sourcing your workspace.

cd ~/ros2_ws
colcon build
source install/setup.bash

Hi @MustaphaJames ,

Adding to what @albertoezquerro has mentioned, I think you have forgotten to add launch directory in your CMakeLists.txt file.

Add the following line to your CMakeLists.txt file and your problem should be fixed:

# install launch files
	launch   # <--- add this line!

Let me know if you still have issues.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.