Jupyter Notebook display issue

Hi there,

I am trying to work with the jupyter notebook for the ROS-Extra Class 2 (Autonomous navigation using GPS) and I cant view the entire jupyter notebook. It seems displaced to the extreme left and do not know how I can resize or reset to the center/ default settings. New to the RDS(ROS Development Studio) and also to jupyter notebooks. Can you please help ?

Hi there!

Can you see the top of the notebook? If so, you should find a button to maximize the window.

If you can see the top, then the problem might be from your browser window. Try to restore and/or maximize your browser window then.


Thank you for getting back. Unfortunately I can not see the top of the notebook. I tried reloading the jupyter notebook and the browser but the problem is still there.

I removed the project and forked it again but turns out the problem is still there. I would be glad if you could look into this.

Hi @Abhijit03 ,

We detected an issue that prevents you from dragging or even closing the app by using the user interface. I’m already working to solve that.

In the meantime, you can try a technical solution that is:

  • Open the console of the browser (F12 or Ctrl+Shift+C)
  • Click on Console tab
  • Execute the command below:
  • Copy and paste localStorage.clear('desktopRosjectApps')
  • Press enter
  • Then reload the page

Get back to the rosject/desktop page. You should have it restored, the notebook opened with its default size.

Please, let me know if that works for you and thank you for your comprehension


Hi @Abhijit03 ,

We have that issue solved, you shuold neither experience the error nor follow the instructions sent previously to to unblock your workspace.

Please, let me know if you need any help.