It's my error or network issuess?

i try this, but it cannot ping too
rm -rf /home/user/catkin_ws/src/
rm -rf /home/user/catkin_ws/build/
rm -rf /home/user/catkin_ws/devel/
mkdir -p /home/user/catkin_ws/src/
cd /home/user/catkin_ws/
this last image it’s from another clean rosject

i found this topic but im not trying to connect to a real robot via RRL
Can’t run roscore on my local machine (robot) after installing the Real Robot Lab client - ROSDS Support - The Construct ROS Community (

Hello @AlfMachine ,

That is very strange. Where is it happening? Is it inside one of our courses? I would try to reset the Shell (by clicking on the red cross in the top-right corner of the Shell) and see if that fixes the issue, since it looks like a Shell misconfiguration issue.

i’m in the rosject doing the project of ros basic in 5 days c++

i check if in the course is working but the terminal says the same, in ros basic in 5 days c++

Hi @AlfMachine ,

I think the master port number has changed.

Try export | grep ROS and export | grep ros on the terminal and post the results here. Maybe that can help debug this issue.

– Girish

looks like it’s that but i don’t know how or why, i was just doing the actions part

@AlfMachine ,

I think you can fix it by doing: export ROS_MASTER_URI="http://master:42801"

Let me know if that worked for you.

  1. do the above command in a terminal.
  2. recompile your package and try to execute.

I hope this fixes your issue!


no, it changes everytime i roslaunch, it doesn’t ping too

@AlfMachine ,

Ok… hmm… that is now a weird problem. I have no ideas how to fix this.
Maybe @albertoezquerro can help you out.


1 Like

Thank you very much, the solution that you give me looks very accurate but it might be more stuff behind this error

1 Like

@albertoezquerro @bayodesegun any solution? i keep having this problem and i cannot continue with.
any support email or something, i try to call but no one anwser

The error you are seeing looks very much like a network issue like you have guessed.

Are you behind a proxy or VPN or something? Something in your network configuration seems to be blocking our services from connecting to the Internet.

One quick test to verify this would be to try another PC connected to another network.

can it be that my remote desktop or virtalmachine added to my account is off or blocked for something? because it’s bloked in every pc i try and in difderent networks. This is happening me since wednesday.

Not all all.

Is this happening on this course only? If so, perhaps you have added some things to your ~/.bashrc that’s causing this…

Could you please try the another course (say the Python version of the course for example)?

in python gives me the same error

Hi @AlfMachine,

the ROS_MASTER_URI, as far as I can see in your messages, is pointing to master, but it is really wrong, because it should be pointing to simulation.

Could you tell us which output the commands below show?

env |grep ROS

env | grep simulation

env | grep gazebo

Could it be that you somehow manually exported the ROS_MASTER variable through a script to point to master?

The ROS_MASTER_URI should contain a _simulation suffix.

If you run the commands below, it should work:

slot=$(hostname  | cut -d'_' -f1)

export ROS_MASTER_URI=http://${slot}_simulation:11311

env | grep ROS

# Now, your script should work
rostopic list

Please let us know how this test goes.

If it works, you could append those two commands to the end of the /home/user/.bashrc file, so that it will export correctly each time you reload the terminals (when the course is opened)

slot=$(hostname  | cut -d'_' -f1)

export ROS_MASTER_URI=http://${slot}_simulation:11311

i don’t know what really happend but i did nothing since friday and now it’s working again, if you fix this thank you all

This topic was automatically closed after 18 hours. New replies are no longer allowed.