Issue in Robot Manipulgation, arm crashing into table

Hi The Construct, All,

In Motion planning using graphical interfaces part 2 (in ROS Manipulation 5 days - Unit 4)

Was just following the instructions and when I put the table object in Gazebo and planning a home position (from the start position), The robot arm just crashes to the table without stopping…, which was supposed to avoid that from its pointcloud feed in from the camera into MoveIt planner, it should avoid crashing the arm to the table, please advice on this issue I’m having?

Hello @wai.mak ,

Are you seeing the octomap points in your MoveIt screen (like it’s shown in the notebook image)? If you are not, you should try to spawn the object with a little bit more separation to the robot. You can tune this in the x parameter of the command:

rosrun gazebo_ros spawn_model -file /home/user/catkin_ws/src/table.urdf -urdf -x 1.5 -model my_object

Make sure that you can properly visualize the octomap points before trying this exercise.

@albertoezquerro ok, I will give it a go,

and in same course, number 6 - Grasping , I followed the instructions and typed in this:

rosrun gazebo_ros spawn_model -database table -gazebo -model table -x 1.30 -y 0 -z 0

to spawn a table but I get this and no table spawned…, please advice, (am struggling to get through these units…)

and same for this command:
rosrun gazebo_ros spawn_model -database demo_cube -gazebo -model grasp_cube -x 0.65 -y 0.15 -z 1.07

please advice

Hello @wai.mak ,

Please use these commands instead:

rosrun gazebo_ros spawn_model -database table -model table -sdf -x 1.30 -y 0 -z 0
rosrun gazebo_ros spawn_model -database demo_cube -model grasp_cube -sdf -x 0.65 -y 0.15 -z 1.07

ok @albertoezquerro, those two works now thks…is best you update that in the unit as well,

I found another problem with the - myrobot_planning_execution.launch.

in Unit 3 - building a Moveit Package (inside the ROS for Industrial Robots 101 course)

near the end , I just try to launch the file above, and it gives me all these errors:

Please fix and advice, (got frustrated again…)

Hello @wai.mak ,

It looks like in your launch file you are calling a package named myrobot_moveit_config, which doesn’t exist:

ResourceNotFound: myrobot_moveit_config

Maybe you meant my_robot_moveit_config instead?

@albertoezquerro , ok I will be checking thanks

  1. also, I’m near to completion on ROS Manipulation in 5 days , do you reckon I need to complete ROS for Industrial Robots 101? this course seems quite similar to the 5 days Manipulation one?

  2. also, I see notification popping up asking me to migrate to Noetic…, Im confused in what to do? I thought these environment for the courses are updated by you or theconstruct itself? shouldnt that be…, please advice

  3. also, how can I save the notebooks inside each unit/chapters ? Coz I have to look back and forth looking for answers and commands and concepts to complete projects…, it is very time consuming

Hello @wai.mak ,

  1. No, you don’t need to do the ROS Industrial course since the contents are already covered in the ROS Manipulation course.

  2. Yes, the migration is done by us. You are already working on ROS Noetic for this course so don’t worry about that message.

  3. It’s not possible to save the notebooks of the courses since they could be used for the wrong purposes. You can though review any notebook at any point by clicking on this blue book icon in the top-left corner of the notebook:

1 Like

ok @albertoezquerro , thanks for the answers to those ones, the blue book icon is handy

Now, I really struggle with this one below :

  1. I have an issue with the project in ROS Manipulation in 5 days, I was trying to execute a plan to the simulated RB1 robot and got the error below,

this is my setting for the controller in ros_controllers.yaml:

I’m not sure what I’m missing here? please advice

Any updates please? I’m still waiting …to progress on…,

I have tried adding joints of the arm by “add joints” in planning group section and also tried add_kinchain (base link and tip link)

I still get these errors…(IT seems like what I learnt in previous chapters , I applied to the project…ERRORS comes up…various of them above and below )

Please advice…I’M STILL waiting! Very frustrating about it…!

Hello @wai.mak ,

I’ve sent to your e-mail a working example of a MoveIt package for the Mico robot so that you can have a look at it and compare it with yours.


Hi @albertoezquerro ,

I tried your MoveIt package thank you and moved the actual arm works now, (how I defined the planning group and ROS controller, I made mistakes).

But just using purely your package has generated the gripper error below, please advice how to fix,

Hello @wai.mak ,

We are working on modifying some things in this project in order to make it more accessible to students. I suggest you move on to other courses in the meantime. I’ll let you know once we have updated it.

@albertoezquerro , ok I see, yea it would be great if the gripper works as well,

Now that I have gone through this course of Robot Manipulation, I would want to apply it to my robot which is based on arduino connecting to several servo motors, do you have any suggestions and advice on where to find an arduino sketch generator on ROS for my robot? thks

Hi @albertoezquerro , do you have any updates on the question above please? ths

Hi @albertoezquerro , All,

any updates on this one please?

Hello @wai.mak ,

For using Arduino with ROS you should have a look at the rosserial packages: rosserial - ROS Wiki