IDE syntax coloring not found

Hello, I can’t seem to have syntax coloring using the IDE. I try to find other language modes but I don’t find CPP nor Python. The IDE seems to be based on VS Code, but where can I download these language modes?
Thank you.

Hello @hobyr ,

Are you still having this issue? Could you share an image of what you get in the IDE?

I’ve been doing some tests and C++ and Python should have correct syntax coloring.

Hi! Yes, the problem is still here. And when I try to select other language modes, there’s nothing else than JSON with comments or Plain Text. I don’t know how to have other language modes, especially since I checked in the plugins the CPP and Python plugins seem to be installed.

Here’s a screenshot of my IDE.

Thanks for your help.

It looks like your browser is blocking some features of the IDE. As you can see in the images below, syntax highlighting works and you can select the languages (I’m using Firefox 89.0.1 (64-bit) on Windows 10):

What you can check, easiest first:

  1. Update your Firefox browser to the latest version.
  2. Try the Chrome browser, ensure it’s up to date.
  3. Check this post for possible reasons why the IDE is being blocked.


I forgot to mention I’m working on Ubuntu Linux. I’m using Firefox 90.0 on Ubuntu so I assume it’s the latest version. I already disabled my adblocker UBlockOrigin suspecting this was the problem, but it hasn’t changed anything. I have a lot of extensions blocking cookies and ads but I disabled all of them to work on the course but I still don’t have the syntax highlighting.

I’ll first check if Chrome under Ubuntu works, if not I’ll check how it works on Windows 10.
I’ll get back to you, thanks for your help.

Alright, I tried disabling every blocker in Firefox but it didn’t work. I tried Chrome and it was fine. Now I’m using Brave browser which also works so I’ll stick with those options.

Thank you so much for your help.

1 Like