I have a campus access license but cannot connect real robot

I have a campus access licence based on my profile and privileges show that I can do real robot connection. However, I am unable to connect or have an option to connect a real robot.

@girishbala95 ,

Welcome to this Community!

By “real robot” if you mean connecting to the robots from The Construct’s Real Robot Lab, then you must first make a reservation/booking with any of the robots available from Real Robot Lab, accessible from your home page after logging in.

If you want to connect one of your own physical robot then I cannot help you with that.

Regards,
Girish

1 Like

Hi Girish,
as @girishkumar.kannan mentioned with the Campus license you can connect to The Construct’s remote robots or you can connect to your own robots.

To connect to The Construct’s robots:

  • For a Campus license, you can only connect to the Turtlebot3 or the Robotic Arm.
  • For that, go to this page, and book a day and time with the robot you want to use.
  • Then, at that time, open a rosject and connect to the robot using the connect button.
    You can see how to do all that in this video

To connect to your own robots:

  • You can register your own robots and then connect to them from a rosject
  • For configuring it (only required once) go to the My rosjects section
  • There click on Connect your robots
  • Then click on Configure my robot. Follow the steps to configure it.
  • Once configured, your robot is registered at The Construct. You don’t need to repeat this process anymore
  • Now you can connect to your robot any time. For that, open a rosject and then, once the rosject is open, click on the icon to connect to your robot. That’s it.

I’m getting stuck on Step #3 above. When I click on the “+” symbol under “Connect Your Robots” I just get an empty pop-up window called “Available Robots” with no option to “Configure My Robot”. I’ve tried Firefox, Chrome, and Edge browsers, but it’s the same result for each.

Hi @martince444 that is definitely an error in the system. You should see an additional button with the option to add your own robot, like in this image

We are reviewing this issue right now and we will come back to you along today with the solution

This issue has been resolved. Apologies for the glitch.

Please try again and let us know.