I cannot open the rviz window on the webshell


I tried the command: rosrun rviz rviz on the webshell, but I cannot open the rviz window. Can anyone help me to solve the problem? Thx.

I assume you may not run roscore before running the command?

run roscore in another terminal and try again.


If this is not the solution, please share the error message so we can understand more about the problem

I tried in terminal 1:
user:~$ roscore
… logging to /home/user/.ros/log/c0e6663a-8d62-11ee-865b-0242ac170007/roslaunch-3_xterm-1580.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://3_xterm:41515/
ros_comm version 1.15.9



  • /rosdistro: noetic
  • /rosversion: 1.15.9


WARNING: ROS_MASTER_URI [http://3_simulation:11311] host is not set to this machine
auto-starting new master
process[master]: started with pid [1596]

setting /run_id to c0e6663a-8d62-11ee-865b-0242ac170007
process[rosout-1]: started with pid [1606]
started core service [/rosout]
In terminal 2:
user:~$ rosrun rviz rviz
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-user’
[ INFO] [1701116841.553427244]: rviz version 1.14.4
[ INFO] [1701116841.553725802]: compiled against Qt version 5.12.8
[ INFO] [1701116841.554100167]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1701116841.598592772]: Forcing OpenGl version 0.
[ INFO] [1701116841.877228352, 171.705000000]: Stereo is NOT SUPPORTED
[ INFO] [1701116841.878007668, 171.706000000]: OpenGl version: 3.1(GLSL 1.4).

After running the rviz command, it should open up automatically. However, if it does not, you can manually open it by clicking on the Graphical Tools icon in the bottom bar:


I opened the Graphical tools, but it shows as follows:

That means there is nothing to show in Rviz. Is your simulation running?

If a simulation is running, then which course or specific rosject are you working on? If rosject, can you share a link to the rosject?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.