Gray screen for Real Robot Lab simulation on ROS Basics project (gzclient)

When trying the rosject of the final project of the ROS Basics in 5 Days course, which contains a simulation of the Real Robot Lab, only a gray screen is shown:


Ok, the “problem” is that the user_camera on the GUI was just too close to the simulation.

It can be solved in two ways:

  1. Zoom out (just by zooming out you should be able to see the simulation properly)
  2. Change the user_camera position in the file if you don’t want to zoom out each time you open the simulation

To change the world file, just open the realrobotlab_simulation/realrobotlab/worlds/ file and look where the user_camera is defined by looking for camera name='user_camera'.

The correct position to show the simulation properly is:

<gui fullscreen='0'>
  <camera name='user_camera'>
    <pose>2.082248 0.691252 1.153800 0 0.509800 -2.815194</pose>

After changing the camera position it should load properly when you reopen the rosject:


Unfortunately it seems the issue is still there. I havent been able to get it running for the past days, even after changing the camera angles.

Hi Tor,

Is this the same rosject you’ve used in the past or has this never worked before for you? I see that the URDF spawn is failing, and that sometimes happens and needs a restart. I just tried this rosject and it worked fine for me:


Yes it should be the same as always. It’s always worked.
I followed your link, which brings to a page that asks me to update the ROSject, which i but i receive the following error:
I’ve tried both in Chromium and Firefox. Same thing.
I’ve backed up my projects, so if you’re able to update it from your end, please do.

Thank you

Could you please try removing the previous rosject and then getting a new copy with the link Learn Robotics from Zero - Robotics & ROS Online Courses?

1 Like

Hi @torpanvil

I went to your profile page ( and copied your rosject.

I then opened the file simulation_ws/src/realrobotlab_simulation/realrobotlab/worlds/ mentioned in this post, but your file still has the old wrong pose. That is on line 220.

After changing in my forked rosject the pose on line 220, it showed properly. And when I opened the rosject before the changes, just zooming out made the simulation show properly, also.

Could you please change line 220? You said you changed the position, but maybe you forgot to save the file?


@bayodesegun @ralves Deleting the rosject and opening the new veresion did not fix it. However, changing the camera worked this time around. Thank you.