Grasping_msgs does not work


I want to build the package on the last part of the ROS2 Manipulator course and I get this error:

I tried to install the grasping_msgs package manually with

sudo apt update
sudo apt install ros-humble-grasping-msgs

But this did not solve the issue.

So I also tried with cloning the package

git clone -b ros2`

But this did also not resolve the issue.

It is weird, because yesterday it did work. And today I am getting this error without having changed anything.

Any help please

Which specific package are you trying to build? Is it moveit2_scripts?

moveit2_scripts is the package that had this error, and the error was that it could not find the dependency grasping_msgs/action/.....

In addition to ensuring that the grasping_msgs package is available, you also need to ensure that it is properly included as a dependency in moveit2_scripts, and the best way to do that is to include it when creating that package.

Hi @bayodesegun

Thanks for the response. You were right, there was a little mistake in the CMakeList.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.