Gmapping is not good

Hello, teachers.

I am trying to implement gammping to my own project. I am getting a very poor performance error.

Is something wrong with my lidar URDF settings or gmapping parameters?

Hi @xj2106 ,
Try reducing the linear and angular velocity, that is how fast it moves. The slower it is, the better. Higher speeds lead to erratic readings.

Let me know if this changes anything.

Thank you @Joseph1001 I tried the method you suggested, it didn’t work out :frowning_face:

Can you share the yaml file you are using which contains all the necessary parameter for gmapping.

When moving the robot using robot teleop, keep the speed under 0.2 for linear and angular.