Gazebo simulation world not loading

hello there, iam trying to work on ‘line following drone’ using this ROS Developers LIVE Class #86: How to use OpenCV with ROS - YouTube , but instead of using ROS Development Studio, iam using it locally in my PC ROS Melodic version(even tried in ROS Kinetic version). I tried launching the simulation environment using the command “roslaunch drone_in_line start_sim.launch” but the in gazebo it isn’t loading as illustrated in the video. i get a unloaded environment where the drone falls off due to no plane to land on. i have added the pic of my resulting gazebo simulation.

please do let me know what is the solution so i can run the same tutorial in my pc locally and connect with my real ardrone 2.0
i get the following errors in the terminal while the gazebo runs,

i have added the launch file code down below,


    <include file="$(find aibo_description)/launch/aibo_tc_start_world.launch" />
    <include file="$(find tc_worlds_robots)/launch/spawn_hector.launch" />


please do help me solve this issue! thank you!

Hi @BadhriROS ,

the first error message says it cannot find the course_web_dev_ros package.

You can solve that error by cloning the following repository in your workspace:

cd ~/catkin_ws/src
git cone

cd ~/catkin_ws
source devel/setup.bash

In see in the last image it also complains about libgazebo_ros
You can just install gazebo_ros_pkgs:

sudo apt-get install ros-noetic-gazebo-ros-pkgs ros-noetic-gazebo-ros-control
sudo apt-get install ros-melodic-gazebo-ros-pkgs ros-melodic-gazebo-ros-control
sudo apt-get install ros-kinetic-gazebo-ros-pkgs ros-kinetic-gazebo-ros-control

Please let us know if you succeeded.

hello there, thank you for the reply. i tried the above process, but unfortunately i still got the same issue in the gazebo simulation, but this time there are no errors…just few warnings!

the gazebo seems have the same issue still!

I would recommend you running:

ps faux | grep gazebo

This will show you the command used to launch gazebo.

Then you run the same command, but adding the option “--verbose” in the end. This would redirect the logs of gazebo to the screen, then you can know why it is not showing something.

There are also logs in the “~/.ros” and “~/.gazebo” folders.

i get something like this;

but i couldn’t understand what does it mean! Please let me know whether i can do something to solve this problem