Gazebo simulation of Rosject - Part I remains empty

I’m currently new to The Construct and doing a ‘ROS basics in 5 days (Python)’ course. As showed in the picture, I tried opening my first Rosject. The first assignment is to just run the simulation using the command: roslaunch realrobotlab main.launch

However, this doesn’t work. I’ve seen on the forum that I should not worry too much about the errors, however the maps doesn’t occur and I don’t know how to fix it.

What I have tried to fix it already:

  • Zoom in / scroll (I really don’t see anything here)
  • Delete the project and copy it again
  • Check if there is a main.launch file

What can I do to continue?

Hi, welcome to the community!

You should check if your simulation is publishing any topics with

rostopic list

and the simulation launched. If it isn’t, then simply kill the simulation with Ctrl+C on the same terminal and launch it again.

You should press on the grey screen of where the simulation should be and just zoom out, it’s there… I’ve wasted a lot of time on that too

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.