Exercise 2.3: No Map received in Rviz2

I’ve followed the instructions to launch ‘map_server’ and ‘lifecycle_manager’ nodes and I’m able to successfully launch them. But couldn’t understand why am I unable to view the map topic in Rviz. Any idea on what could be the reason. Could anyone please help me out. Thanks in advance.

Hi, welcome to the community!

This sometimes happens if you don’t have the configuration how it should be. The map_server also only loads the map one time, so I recommend having rviz2 open with the map topic added before you launch the map_server

1 Like

Hey thanks a lot Gonzalez (@roalgoal). I’ve followed your suggestion and it worked. Could you please elaborate on what you meant by ‘not having the configuration how it should be’. Just want to understand your thought process.

I just mean that you might have missed the correct name of the scan topic or a frame name, but if it worked now, then I see that you configuration must be correct

1 Like

This topic was automatically closed after 22 hours. New replies are no longer allowed.