Errors in project ROSManipulationIn5Days Unit 6


I was trying to perform the project in Unit 6, but it seems to be that some files are disappearing when going from Unit 5 to 6.
The first part of the project goes smoothly, the problems start in the 3rd point, when it is asked to build a python script to go trough all the possible poses. I have tried to build it using the code from Unit 5, but I keep getting this error.

I also attach my code (you can see that is really similar to the used in Unit 5

Thank you in advance!

Hi there,
It seems like this is a Python specific problem. Can you try to replicate the following commands?


Hello, thank you for replying me, this is what I’m getting from both unit 6 and 5:

Best regards,

But the strange thing is that the program in unit 5 ( of module simple_grasping) runs flawlessly.


I have just tried to import moveit_python in unit 6 and indeed it seems like this module cannot be found. So i believe that the Python environnement for this unit doesn’t include this module.
Maybe @albertoezquerro can fix the problem?


Hello @VincenzoScamarcio and @mouad.abrini ,

I’ve just updated the project environment to include moveit_python, so you should be able to use without problems now.


Hello @albertoezquerro,

thank you for trying to help me, unfortunately when I try to run the aforementioned program, the same message keeps appearing:

user:~$ rosrun rb1_robot_mico_moveit_config
Traceback (most recent call last):
File “/home/user/catkin_ws/src/rb1_robot_mico_moveit_config/scripts/”, line 8, in
from moveit_python import (MoveGroupInterface,
ImportError: cannot import name ‘MoveGroupInterface’ from ‘moveit_python’ (/home/user/catkin_ws/devel/lib/python3/dist-packages/moveit_python/


Hello @VincenzoScamarcio ,

I was able to solve it by removing the build and devel folders from the catkin_ws and recompiling. For some reason, it was trying to access the module there as you can see in the last line of the error.


Hello @albertoezquerro,

thank you for the hint, I did it and the error message disappeared.

The problem that lasts is that, when I launch my program (you can find the pics in the first question of this topic) the robot does not start to move and in the shell nothing appears. When I press Ctrl+C then the program stops and launches the message in the last line of the code (rospy.loginfo “finished”).

Could you also help me with that? Thank you in advance,

Vincenzo Scamarcio