Error with package

I believe I have a problem with my package which I have created for the first part of the Rosject.

The Problem: I cannot launch or run run package.

what I have tried:

firstly I tried launching with roslaunch - I recieved an error saying that “[laser_pkg_launch_file.launch] is neither a launch file in package [laser_pkg] nor is [laser_pkg] a launch file name”

  • I double checked the names, the permission of my .py file and deleted and remade the /build and /devel

when I try and use rosrun I get and error " Error: package ‘laser_pkg’ not found"

and finally I tried going into the launch directory and launching from there and I received and error " ERROR: cannot launch node of type [laser_pkg/]: laser_pkg"

Hi guys,
Here is an update for anyone who had a similar issue:
I ended up making a new package and launching that, this worked and so I do believe it was an issue with the package itself.

1 Like

I’m glad you found the issue! A good thing to remember is to also run the command

rospack profile

After you have compiled your package to make sure ROS can find the package.