Error while launching service_client_pkg

While attempting exercise 5.1 in the ROS Basics in 5 days (c++), I keep coming up with the error as seen below.
While executing catkin_make, it seems as though the service_client_pkg package is not recognised.
I have also tried sourcing ros, but didn’t seem to work.
Any help would be greatly appreciated!

user:~/catkin_ws$ source devel/setup.bash
user:~/catkin_ws$ catkin_make
Base path: /home/user/catkin_ws
Source space: /home/user/catkin_ws/src
Build space: /home/user/catkin_ws/build
Devel space: /home/user/catkin_ws/devel
Install space: /home/user/catkin_ws/install
#### Running command: "make cmake_check_build_system" in "/home/user/catkin_ws/build"
#### Running command: "make -j8 -l8" in "/home/user/catkin_ws/build"
[  0%] Built target rosgraph_msgs_generate_messages_py
[  0%] Built target roscpp_generate_messages_py
[  0%] Built target std_msgs_generate_messages_eus
[  0%] Built target roscpp_generate_messages_nodejs
[  0%] Built target rosgraph_msgs_generate_messages_cpp
[  0%] Built target std_msgs_generate_messages_cpp
[  0%] Built target rosgraph_msgs_generate_messages_eus
[  0%] Built target rosgraph_msgs_generate_messages_lisp
[  0%] Built target roscpp_generate_messages_lisp
[  0%] Built target std_msgs_generate_messages_lisp
[  0%] Built target rosgraph_msgs_generate_messages_nodejs
[  0%] Built target roscpp_generate_messages_eus
[  0%] Built target roscpp_generate_messages_cpp
[  0%] Built target std_msgs_generate_messages_nodejs
[  0%] Built target std_msgs_generate_messages_py
[100%] Built target obstacle_avoider
user:~/catkin_ws$ roslaunch service_client_pkg service_client_launch.launch
... logging to /home/user/.ros/log/336d4f1e-963a-11ed-9cb3-0242ac150007/roslaunch-2_xterm-11575.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://2_xterm:39355/


 * /rosdistro: noetic
 * /rosversion: 1.15.9

    iri_wam_reproduce_trajectory (iri_wam_reproduce_trajectory/iri_wam_reproduce_trajectory_node)
    service_client (service_client_pkg/simple_service_client)
    traj_by_name_node (trajectory_by_name/


process[iri_wam_reproduce_trajectory-1]: started with pid [11583]
process[traj_by_name_node-2]: started with pid [11584]
ERROR: cannot launch node of type [service_client_pkg/simple_service_client]: Cannot locate node of type [simple_service_client] in package [service_client_pkg]. Make sure file exists in package path and permission is set to executable (chmod +x)
[ INFO] [1673947273.851293487]: Waiting for action server to start.
[ INFO] [1673947273.881770691]: Ready execute trajectories

Building the package with the following command solved the issue

catkin_make --only-pkg-with-deps service_client_pkg