Error Unit 8 - roslaunch ardrone_as action_server.launch

I wanted to report an error related to “roslaunch ardrone_as action_server.launch”.

I am getting the following error.

“RLException: [action_server.launch] is neither a launch file in package [ardrone_as] nor is [ardrone_as] a launch file name
The traceback for the exception was written to the log file”

Since this is the main package to complete the exercises of Unit 8, I am stuck and not able to complete the course.

Also, I tried to check whether ardrone_as package exist and the server responded as follow.

user:~/catkin_ws$ roscd ardrone_as/action; cat Ardrone.action
roscd: No such package/stack ‘ardrone_as/action’
cat: Ardrone.action: No such file or directory

Hi @1666c563_86fb_46ec_b42b_1e7eb3e50ebb ,

I just tried the exact same command, it is working fine for me.

user:~$ roslaunch ardrone_as action_server.launch
... logging to /home/user/.ros/log/f25d300e-ca58-11ed-8602-0242c0a83006/roslaunch-3_xterm-1123.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://3_xterm:36259/


 * /rosdistro: noetic
 * /rosversion: 1.15.9

    ardrone_as (ardrone_as/


process[ardrone_as-1]: started with pid [1139]

I suggest that you reload the page and try again the same command.

Let me know if your problem still happens.


Instead of reloading, you can also run

source /home/simulations/public_sim_ws/devel/setup.bash

Then run the roslaunch command again.