ERROR: Unable to communicate with master!

I am working on the second part of the Rosject and when trying to run rostopic list I get the following error:

ERROR: Unable to communicate with master!

I tried sourcing the shell and reloading the whole website but it still occurs.
Any suggestions?


Maybe the simulation died for some reason . If you click on the restart button in the simulation window:

It should restart everything, including the ROSCORE.

If this isn’t so please post a video or images of the issue so we can solve it.Dibujo sin título

I am only using the webshell and the code editor. I haven’t opened the simulation yet so there is no restart button. I did close the website and logged in again but it still doesn’t work.
I can post a picture but there isn’t anything else to see except for the error message I mentioned.
In order to not waste time, I continued with the next unit while waiting for the problem to be solved and this is not happening there. It seems to be a problem with the rosject environment.

Oh, I understand, so its on the ROSject environment.

Could share here the ROsject adn the commands that you used to launch the simulations? I can test from my side and see if there is something wrong with teh rosject

Ok I found the problem. I wasn’t launching the simulation with the command indicated at the beginning roslaunch realrobotlab main.launch. I forgot it.

1 Like