"Error getting RMW implementation identifier" error

I’ve just started Unit 5 of the ROS2 Basics in 5 Days course for Python. The course has worked well up until this point. However, now each time I try to execute a ros2 command in the shell I receive the following message:

[ERROR] [1638221201.517377591] [rcl]: Error getting RMW implementation identifier / RMW implementation not installed (expected identifier of 'rmw_cyclonedds_cpp'), with error message 'failed to find shared library of rmw implementation. Searched rmw_cyclonedds_cpp, at /tmp/binarydeb/ros-foxy-rmw-implementation-1.0.1/src/functions.cpp:54', exiting with 1., at /tmp/binarydeb/ros-foxy-rcl-1.1.9/src/rcl/rmw_implementation_identifier_check.c:139

I’ve confirmed that I’ve sourced the .bashrc_ros2 file at the beginning of the unit. Any help would be appreciated.

Echoing the RMW_IMPLEMENTATION variable returns “rmw_cyclonedds_cpp”.

Same error here, a fix would be nice :slight_smile:

We are working on solving this. Please give us some minutes to solve it


This error has appeared due to a modification (upgrade) we added yesterday to the Academy. My apologies for this, since we should have tested it better to make sure that it didn’t break anything.

In any case, we have already fixed the problem so it should now work OK when you go back to the course. If it’s still not working properly, please let us know.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

To solve this problem on Foxy, you have to install Cyclone DDS:

sudo apt-get update 
sudo apt-get install -y ros-foxy-rmw-cyclonedds-cpp