ERROR: cannot launch node of type [exercise_23/publish_age.py]: can't locate node [publish_age.py] in package [exercise_23]

Why is this happening? How to fix it? (Exercise 2.3)

Hi @steve26

make sure you source the devel/setup.bash after compiling and that the publish_age.py is made executable with chmod +x publish_age.py

1 Like

Hi @steve26,

Welcome to the Community!

As @simon.steinmann91 mentioned, it’s probably an execute permisssion issue. The full reference to this error can be found in this knowledgebase post: