Drone not visible in Gazebo in ROS DEBUG CASES

In Chapter 5, ROS Debug Cases, the goal is to move the drone using action commands.
Here, there is no drone in the simulation, leaving an empty Gazebo as below:

When i ran the cmd rosservice call /gazebo/get_world_properties “{}”, i get sjtu_drone as one of the models in the simulation, but not visible in the simulation.

sim_time: 585.87
model_names: [robocup_3Dsim_field_0, grey_wall, jersey_barrier, nist_stairs_120, nist_maze_wall_240,
  nist_elevated_floor_120, nist, jersey_barrier_0, sjtu_drone]
rendering_enabled: True
success: True
status_message: "GetWorldProperties: got properties"

I tried the solution from @albertoezquerro at Click Link, i get the following result:

user:~$ git checkout kinetic-gazebo7

> fatal: not a git repository (or any parent up to mount point /home)
> Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

Can you guide me on this?

Hi @Joseph1001 ,

thanks for reporting the issue.

This was actually a problem on our side. Gzweb was reporting that the models/sjtu_drone/quadrotor_4.dae file does not exist.
I just published a fix. How the drone should load properly.

Again, thank you very much for reporting it.

1 Like

@ralves , i just checked, its working well now, thanks for helping out. Could you also create a category to post Queries related to Debug Cases course, since i could not find one in the scroll down menu, and hence had to post this topic under “General Support” category.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.