Dissappointed in all of the bugs

Hello, I am finding the interface to be incredibly buggy. It only loads correctly about 33% of the time and at the very least I usually have to reload one or more of the windows. At the time of this post the interface wouldn’t even load for about 15 minutes and this happens relatively frequently. Is there a fix for this? Maybe a local cache that I can create?

1 Like


Sorry to hear that. Could you post here your system specifications, the browser you use ( version if possible ) and the internet speed you use normally? Which courses are you experiencing this in?
This data will help us evaluate what could be the issue. Take into account that things like the 3D models and so on are normally saved already in cache, so the fits time models should load slower than after. But these issues that you are experimenting are not at all normal.

Basic System Specs:
Windows 10
Intel i7
16 GB or RAM
NVIDIA Quadro M3000

Firefox 85.0

Internet Speed:
20 MBps

At the time I am writing this, I am trying to correct the services_quiz (section 6, ROS Basics in Python) and it has been sitting for longer then 10 minutes. I guess I’ll try reloading and grading again…

Update: I have now tried regrading and it failed. I have tried regrading on Chrome but it is also not responding.

Hello @lclemen ,

The error in your quiz correction is with the launch file call_bb8_move_in_square_custom_service_server.launch. You have included inside the launch of the server aswell:

    <!--<include file="$(find services_quiz)/launch/start_bb8_move_custom_service_server.launch" />-->
    <node pkg="services_quiz"


You should remove or comment that line (as I’ve done in the code above). If you check the specifications of the Quiz, you’ll see this is indicated:

We’ve specifically indicated this because it has happened to other users before. In any case, if you fix this and try to correct it again, you will get a mark of 10.


Thanks. Still doesn’t explain the other issues.

One other question, I recieved a mark of 7 on Quiz 4 (topics_quiz) and I can’t see a difference between my solution and yours aside from some slight variations in order of operations.

It dinged me on
:heavy_multiplication_x: No publishing on /cmd_vel (mark: 1.0)

Can you look at that code and let me resubmit if there is nothing wrong?

Hello @lclemen ,

You can resubmit the quiz again. Your code is OK, there was a bug in the correction script that was caught with your case. I’ve already fixed it so you should get a perfect mark now.


@albertoezquerro ,

I tried resubmitting my quiz and all it told me this time was that I got a mark of 7.0…there was not any feedback so I can’t tell you what the grader thought I was doing wrong.

Can you please look into this?

Thanks, Layne

Hello @lclemen ,

I just tried it directly with your code and I got a 10.

Can you please try it again? Maybe when you tested it the latest changes weren’t applied yet…


I can’t. It gives this error


I’ve just reset your number of trials to 1 so that you can send it again.