Display issue in Chrome of Unit 8 ROS Actions: Client


This unit cannot be properly displayed, as shown below.


Hi Zheng,

Welcome to the Community! I’m sorry that you are seeing this glitch.

May I ask how you are accessing this notebook? Are you using a cached/saved version?

I have just tried on Chrome and I cannot reproduce this problem, and all the notebooks are served from the same source.


Thank you for your reply. I opened it in Chrome and expanded it through

I forgot to mention that it’s the C++ unit that cannot display correctly but the Python unit can display perfectly. Did you try the C++ unit and it worked?


Yes, I tried the C++ unit as that’s the category you posted on. And it displayed correctly.

It’s possible that your browser is displaying that notebook from some sort of cache. Weird. Could you please try Microsoft Edge (I tried this) or Firefox?

Yes very frustrating. I tried Edge and it did not work. I also downloaded and installed the firefox. It did not work too. Weird it’s only this unit that doesn’t display properly.
Could it be possible that since it displays properly in your browser, you could help print this page to a pdf and email me, so I could follow the instructions. Many thanks!

I’m very sorry for this glitch.

I have just pushed a change that force a regeneration of this notebook, and I have sent you the PDF version also.

Can you try the notebook again? Also, please try using the Notebook Review widget and load the unit from there. Perhaps, the right format will appear there.



Still it doesn’t display well. Never mind. You’ve sent me the pdf and I can follow the instructions. Thanks again!


1 Like


I have the exact same problem, currently on edge. (I have the same problem on chrome and firefox)
May you send me the pdf too ?

I’m sorry for this glitch. Could you please try to clear your browser cache? It seem that your browser is somehow caching an old version of this notebook.

In any case, I have also sent you the PDF.

But I’ve installed chrome just to try it and it changed nothing