Chmod cannot find filename: no such file or directory

Hi, I am a beginner at ROS and was trying to do the exercise 2.1 of “ROS Learning Week - Day 4” rosject.
When I do the roslaunch command, the following error comes up:
ERROR: cannot launch node of type [exercise_2_1/]: can’t locate node [] in package [exercise_2_1]

When I try to give execute permission by doing chmod +x, the following error comes up:
chmod: cannot access ‘’: No such file or directory

The only thing I did differently from the notebook was, instead of editing in the file from an older example in the same rosject, I made a separate package(exercise_2_1) with separate launch file(simple_topic_publisher_exercise2_1.launch) and python file(

All the locations and names are correct as per my limited knowledge. I even tried running roscore in a separate shell and then tried doing roslaunch and chmod again, but same errors came up. Please help me figure out where I am going wrong.

I have attached a picture containing the locations of files & the launch file code.
This is the python code:
#! /usr/bin/env python

import rospy

from geometry_msgs.msg import Twist


pub2 = rospy.Publisher(’/cmd_vel’, Twist, queue_size=1)

rate = rospy.Rate(2)

var = Twist()

Twist.linear.x = 0.3

Twist.angular.z = 0.3

while not rospy.is_shutdown():



Hi @tsturbo ,

  1. Make sure you have compiled using catkin_make, and later source using source devel/setup.bash, while being in the catkin_ws directory.

  2. run rospack profile. Since you have created a new package, the system maynot yet recognize it and rospack profile will update the list.

Hi @Joseph1001 , thanks for the reply. I tried your solutions, but the same errors are popping up still.

Can you try the following to check if the package exist:

rospack list | grep <replace with name of the package you created>

Do share the result


Hi @tsturbo , i tired to replicate your file but did not get any error as you said.
I did get a lot of errors in your python code you shared, i have commented the same in the code:

#! /usr/bin/env python

import rospy

from geometry_msgs.msg import Twist


pub2 = rospy.Publisher("/cmd_vel", Twist, queue_size=1)

rate = rospy.Rate(2)

var = Twist()
# the object created is var , and not Twist
# Twist.linear.x = 0.3
var.linear.x = 0.3

# Twist.angular.z = 0.3
var.angular.z = 0.3

while not rospy.is_shutdown():


Launch file:

<node pkg="exercise_2_1" type="" name="twisting" output="screen"/>

Why don’t you delete the package and try once again.

I had already tried deleting the package and it didn’t work. I had tried what I had mentioned in my post and it didn’t work. I had tried what you had suggested, Joseph, and it didn’t work.
Following all this, I left it at that time. I picked it up again today, and deleted the old package and started again. It worked this time.
Also, the code fault you had pointed out was correct; thanks a lot. It was a silly mistake on my part which I made probably during a brain-fade moment. I made the correction, and the simulation is running smoothly. It could be that the code fault was the issue itself.
Whatever be the case, I am grateful for your efforts.
Hope we stay connected.


@tsturbo , I am glad it worked out. Do continue to share any queries with the community.

Happy to help.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.