Can't start rviz at local

I trying to do URDF at my local (ubuntu 18.04/ melodic) I can see the shape of the robot like below image but I am having trouble while launching the urdf launch file.

RLException: Invalid roslaunch XML syntax: no element found: line 1, column 0
The traceback for the exception was written to the log file

My package folder is like below

And this is the command I am using :

roslaunch tuvok_description urdf_launch.launch model:='$(find tuvok_description)/urdf/tuvok_description.urdf'

As I understand there is no problem in XML file since I can see it in urdf preview and my launch file same as in the tutor. What can be the problem ? Thanks

Hello @fkaan ,

Indeed, it looks like an error with the launch file taking into account what the error message says. Even though the URDF file looks correct (therefore you can previsualize it), the launch file could be wrong. Could you share here the contents of your launch file?


  <!-- USE: roslaunch my_mira_description urdf_visualize.launch model:='$(find myrobot_package)/urdf/myrobot.urdf' -->
  <arg name="model" default=""/>

  <param name="robot_description" command="cat $(arg model)" />

  <!-- send fake joint values -->
  <node name="joint_state_publisher_gui" pkg="joint_state_publisher_gui" type="joint_state_publisher_gui"/>

  <!-- Combine joint values -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"/>

  <!-- Show in Rviz   -->
  <!--<node name="rviz" pkg="rviz" type="rviz" args="-d $(find my_mira_description)/rviz_config/urdf.rviz"/>-->
  <node name="rviz" pkg="rviz" type="rviz" args=""/>


Hello @fkaan ,

Could you try adding the following line at the beginning of your launch file?

<?xml version="1.0"?>

It works now thanks a lot!!. Can you tell me why we didn’t include

<?xml version="1.0"?>

at tutorial ?

Also at fixed frame base_link doesn’t show up. And adding manually didn’t work. And lastly I don’t if these errors normal.

And my joint frame didn’t show up like in the tutorial

@fkaan Because in the setup used in the Academy, it’s not needed. The courses are tested in the Academy, so replicating them on each person’s local computer might need extra steps.

For instance, the error in the image appears because you don’t have installed the joint_state_publisher_gui package (which is already installed in the Academy). Probably it will get solved by installing it like this:

sudo apt update
sudo apt innstall ros-melodic-joint-state-publisher-gui