Can't see my robot in Gazebo

Right after simulation UI have changed I started facing problems with it.
When I launch my robot into my world, gazebo successfully loads models from the world, but I can’t see my robot, even though all it’s nodes are there. Same thing happends then I try to launch my robot into existing world.

hi @chotabomj, welcome to the community!
i experienced the same problem with my meshes, have a look to this post:

Thank you for your response.
I tried creating new package for my xacro folder and meshes folder with _description at the end as you suggested, but the model still doesn’t show up.

My other robot model without meshes loads just fine, so I tried replacing meshes with box visuals, but it still doesn’t work.

could you send me your package so i can test locally and have a better look?
here is my mail

1 Like

Hi @chotabomj ,

There is also another possibility which is related to the zooming of gzclient
Could you try the solution shown here:

Please, let me know if it’s solved