[Bug] Rust version mismatch

This is an error report.


Screenshot of the error


Error details

Rust version seems to need upgrade for dependent library home

1 Like

Hey! I changed the version for home crate to 0.5.5 by running:

cargo update -p home@0.5.9 --precise 0.5.5

Then I set the version for rclrs to “0.3.1” in the toml file

rclrs = "0.3.1"

That resolved the issue.

@wbertc Thanks for providing a solution.

@mossy321 We’ll review this and update our systems accordingly.

@bayodesegun I got the same issue with the next section, but this fix didn’t work. When I downgraded some of the dependencies, I got compilation errors.

Sorry about that. We are looking into this and will revert ASAP.

1 Like

@bayodesegun any update about this? I’d like to complete this course soon.

Checking it now ;), we will post here as soon as we have something

Hi everyone that had this issue. It seems it’s a deeper issue than we though so we will need some time to see deeper and hopefully fix it. SOrry for the inconvenience, seems that there has been a recent update that has broken the course somehow.

We will post here for updates on the matter as soon as we have them.

Again , sorry for the inconvenience

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.