[Bug] Map not displayed in Rviz2

This is an error report.

Screenshot of the error

Error details

Exercise 2.3: I tried to configure the map display according to the screenshot in course notebook, but it still says "No map received" If I do: ros2 topic echo /map I do get something back, and the header looks correct.

Hello did you have choosen correctly reliability and durability policy?

This is the reliability and durability policy I have, I tried to use the same as shown in course notebook.

Ok, since you have the correct QoS settings, what you can do is:

  1. Confirm that the map_server ran correctly and provided the map (I assume it did because you metion you are able to echo /map)
  2. Uncheck/check the actual “Map” element in rviz2. Since the map server only publishes once, sometimes rviz2 might not catch it.
  3. Restart the map server with rviz2 launched

Thanks a lot for the hints!
Starting rviz before map_server solved the problem.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.