Account license issue

Hi. I am a student at University of California San Diego, and the instructor of my class provides a link that allows us to create an account on The Construct with a license so students can go through courses. Most of the students in the class seem to be able to get the license but not me. I made my account with the link provided by the instructor, and my account uses the school email address. Can you see what’s wrong? I have contacted my instructor many times, and he’s also given me new links many times, but none of them worked.

Hi Nozomu,

You don’t use the link to create an account - you should have an account prior to using the link. I apologize for the confusion.

Please proceed as follows:

  1. Login to your account first.
  2. Click on the link from your instructor, and make sure it opens in the same browser where you logged in to your account. You could also copy the link and paste it in a new tab of the browser where you logged in to your account.

Everything should work fine then. If not, please let me know and add a screenshot of any error message you get.

Btw, welcome to the Community!

Hello bayodesegun,

It worked. Thank yo so much!! Have a great weekend.


I am also a student at UCSD and have been having a similar issue. However I think I had made my account before accessing the link, so I thought it was working. I had made my account, clicked the link, and say the courses I needed for my class at the top of the page, including ROS2 basics. It has been a few weeks, and I am now unable to access the ROS2 basics course, even tough the initial link seemed to have worked just fine. I am also now unable to find the page which had all the courses I needed for my class right at the top for me to access. The professor later sent out another link, which was supposed to be valid for 24 hours. I tried using that link, but it said “This share link is invalid or has expired. Please contact your teacher or team manager.” The link was had only been posted 13 hours earlier, so it should not have been expired yet.

Hey Colin,

I’m about about the issues you are having. Let me clarify some things:

The courses at the top of the page are courses launched recently or the most popular courses if you have not launched any course, not necessarily the courses needed for your class. You can use the search bar at the top to search for any course by its title, or you can click on the Courses link on the sidebar to see a list of all courses.

The expiry time for the link starts counting after it’s generated, not when posted/shared. So most likely your professor posted it hours after it was generated. Please ask you professor for a fresh link. I’m sorry about this; we’ll look into extending the expiry time of these links.

1 Like

Yes, I did suspect that my professor may have sent out the link hours after it was already generated. I asked him for a new one, made sure I was logged in before using it, and made sure I used it as soon as he provided it. This time it worked for me. Thank you for the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.